Previous Thread
Next Thread
Print Thread
Rate Thread
Boost by Gear Stopped Working #455291
May 15, 2019 07:32 pm UTC
May 15, 2019 07:32 pm UTC
Joined: Apr 2006
Posts: 3,863
Los Angeles, California
Alex Akachinskiy Offline OP
Insane Member
Alex Akachinskiy  Offline OP
Insane Member
*****
Joined: Apr 2006
Posts: 3,863
Los Angeles, California
Hello DSMers,
I ran into problem with electronic boost control on my 2g DSM. I have not made any changes that could possible contribute to this problem.
Long story short, i use 3 port ingersoll electronic boost controller with ECMLink.
I have 3 different boost setting for 1st, 2nd, 3rd gear. Currently my DSM follows only 1st gear boost settings in ALL gears.
According to logs, for no reason at all, the value for WGSGear is always being reported as 1st (at any speed in any gear).
This issue got introduce this passed weekend, everything worked normally before.

Here is more info on WSGGear from ecmlink wiki:

WGSGear - The gear the ECU is using for both the Boost Target Target and Base Duty Cycle tables.
This is just a sanity check so you can see for sure which gear the ECU believes you're in.


^Currently i'm stumbled what could cause ECU to loose track of gears.
Anyone ran into this problem before? interested in your thoughts on this

Last edited by Alex Akachinskiy; May 15, 2019 07:33 pm UTC.

1996 Eagle Talon TSi AWD
2006 Mazda RX8 6sp TURBO
2014 EVO X MR

Re: Boost by Gear Stopped Working [Re: Alex Akachinskiy] #455292
May 17, 2019 08:04 pm UTC
May 17, 2019 08:04 pm UTC
Joined: Oct 2010
Posts: 9,929
Caledon, Ontario, Canada
Bryan Lawrence Offline
Senior Member, with Far TOO Much Time on Their Hands
Bryan Lawrence  Offline
Senior Member, with Far TOO Much Time on Their Hands
***
Joined: Oct 2010
Posts: 9,929
Caledon, Ontario, Canada
Take a look here.
Confirm you don't have 1st gear checked for some reason and then go into the direct access table to see if your values for the gears look right.
http://dsmlink.com/wiki/bcsoverview


"Old Blue" 91 Talon TSi AWD
"Super Enthusiast" 91 Talon TSi AWD
Checkout DSMFAQ.com!
Re: Boost by Gear Stopped Working [Re: Alex Akachinskiy] #455295
May 19, 2019 01:18 pm UTC
May 19, 2019 01:18 pm UTC
Joined: Apr 2006
Posts: 3,863
Los Angeles, California
Alex Akachinskiy Offline OP
Insane Member
Alex Akachinskiy  Offline OP
Insane Member
*****
Joined: Apr 2006
Posts: 3,863
Los Angeles, California
Hey Bryan L,
Thanks for reply, hope is all good with you. Still lifting ?

I just doubled checked ecmlink again, everything looks according to specs.
When logging WGSGear, it's always reporting 1st


1996 Eagle Talon TSi AWD
2006 Mazda RX8 6sp TURBO
2014 EVO X MR

Re: Boost by Gear Stopped Working [Re: Alex Akachinskiy] #455296
May 20, 2019 11:56 am UTC
May 20, 2019 11:56 am UTC
Joined: Oct 2010
Posts: 9,929
Caledon, Ontario, Canada
Bryan Lawrence Offline
Senior Member, with Far TOO Much Time on Their Hands
Bryan Lawrence  Offline
Senior Member, with Far TOO Much Time on Their Hands
***
Joined: Oct 2010
Posts: 9,929
Caledon, Ontario, Canada
Hey! You know it, actually starting a new program today as I seem to have plateaued. you?

Ok so did you take a look at this and take any of the approaches mentioned here.
http://dsmlink.com/wiki/bcssetup


"Old Blue" 91 Talon TSi AWD
"Super Enthusiast" 91 Talon TSi AWD
Checkout DSMFAQ.com!
Re: Boost by Gear Stopped Working [Re: Bryan Lawrence] #455297
May 21, 2019 02:38 pm UTC
May 21, 2019 02:38 pm UTC
Joined: Apr 2006
Posts: 3,863
Los Angeles, California
Alex Akachinskiy Offline OP
Insane Member
Alex Akachinskiy  Offline OP
Insane Member
*****
Joined: Apr 2006
Posts: 3,863
Los Angeles, California
Originally Posted by Bryan Lawrence
Hey! You know it, actually starting a new program today as I seem to have plateaued. you?p

A little here and there, nothing crazy or be proud about lol

Originally Posted by Bryan Lawrence
Ok so did you take a look at this and take any of the approaches mentioned here.
http://dsmlink.com/wiki/bcssetup


Sure i did, so internally ECU has a logic to calculate which gear it might be in. I don't know what this logic is but it's not based on speed sensor alone.
The temporary work-around is to just set my 1st gear boost target to a value that will satisfy all my gears, similar to how MBC does it.
However, i do like to get to the bottom of it because something did faile that's causing it.
For starters, if anyone knows how factory 2g ECU Gear logic works that should help us guide in the right direction.


1996 Eagle Talon TSi AWD
2006 Mazda RX8 6sp TURBO
2014 EVO X MR

Re: Boost by Gear Stopped Working [Re: Alex Akachinskiy] #455298
May 21, 2019 07:26 pm UTC
May 21, 2019 07:26 pm UTC
Joined: Mar 2009
Posts: 3,048
Stanstead, Quebec
Jason Drew Offline
Insane Member
Jason Drew  Offline
Insane Member
*****
Joined: Mar 2009
Posts: 3,048
Stanstead, Quebec
Originally Posted by Alex Akachinskiy

For starters, if anyone knows how factory 2g ECU Gear logic works that should help us guide in the right direction.


I'd suggest joining the Ecmlink group on FB, https://www.facebook.com/groups/dsmlinksupportline/
Tom Dorris is on there quite often and will likely chime in.


1997 Eclipse GST - AWD swapped - TPC - R Spec powered
2019 - 10.45 - 137mph
Re: Boost by Gear Stopped Working [Re: Jason Drew] #455303
May 23, 2019 04:51 am UTC
May 23, 2019 04:51 am UTC
Joined: Apr 2006
Posts: 3,863
Los Angeles, California
Alex Akachinskiy Offline OP
Insane Member
Alex Akachinskiy  Offline OP
Insane Member
*****
Joined: Apr 2006
Posts: 3,863
Los Angeles, California
Originally Posted by Jason Drew

I'd suggest joining the Ecmlink group on FB, https://www.facebook.com/groups/dsmlinksupportline/
Tom Dorris is on there quite often and will likely chime in.


I've been out of facebook for awhile but defiantly good suggestion! Anything he might said about ecmlink v4 ?
BTW regarding the issue itself, i may have found the problem and it points to user error.
I will test my dsm over next two days (hopefully time permits) and report back the results.


1996 Eagle Talon TSi AWD
2006 Mazda RX8 6sp TURBO
2014 EVO X MR

Re: Boost by Gear Stopped Working [Re: Alex Akachinskiy] #455306
May 29, 2019 09:21 am UTC
May 29, 2019 09:21 am UTC
Joined: Oct 2010
Posts: 9,929
Caledon, Ontario, Canada
Bryan Lawrence Offline
Senior Member, with Far TOO Much Time on Their Hands
Bryan Lawrence  Offline
Senior Member, with Far TOO Much Time on Their Hands
***
Joined: Oct 2010
Posts: 9,929
Caledon, Ontario, Canada
Hey Alex, I can ask for you and report back as I am curious about this. Odd that the logic isn't mentioned, I figured those numbers had to do with your load.


"Old Blue" 91 Talon TSi AWD
"Super Enthusiast" 91 Talon TSi AWD
Checkout DSMFAQ.com!
Re: Boost by Gear Stopped Working [Re: Bryan Lawrence] #455307
May 29, 2019 11:19 pm UTC
May 29, 2019 11:19 pm UTC
Joined: Apr 2006
Posts: 3,863
Los Angeles, California
Alex Akachinskiy Offline OP
Insane Member
Alex Akachinskiy  Offline OP
Insane Member
*****
Joined: Apr 2006
Posts: 3,863
Los Angeles, California
Originally Posted by Bryan Lawrence
Hey Alex, I can ask for you and report back as I am curious about this. Odd that the logic isn't mentioned, I figured those numbers had to do with your load.



yep i have update on the issue. It was user error after all.
Don't know how (but no one to blame except me) i had check box value checked where it should not be.
Maybe during those drunktimes/nightwalks ...sitting in the car and poking around

[Linked Image]
^ this must be un-checked. Only checked when automatic transmission otherwise ECU will not calculate gear in 5MT DSM

Took her for a spin around the block, and boost by gear is where it needs to be.

[Linked Image]


1996 Eagle Talon TSi AWD
2006 Mazda RX8 6sp TURBO
2014 EVO X MR

Re: Boost by Gear Stopped Working [Re: Alex Akachinskiy] #455308
May 31, 2019 10:36 am UTC
May 31, 2019 10:36 am UTC
Joined: Oct 2010
Posts: 9,929
Caledon, Ontario, Canada
Bryan Lawrence Offline
Senior Member, with Far TOO Much Time on Their Hands
Bryan Lawrence  Offline
Senior Member, with Far TOO Much Time on Their Hands
***
Joined: Oct 2010
Posts: 9,929
Caledon, Ontario, Canada
Nice, that's great to hear!


"Old Blue" 91 Talon TSi AWD
"Super Enthusiast" 91 Talon TSi AWD
Checkout DSMFAQ.com!

Powered by UBB.threads™ PHP Forum Software 7.6.1.1
(Release build 20180111)
Page Time: 0.034s Queries: 15 (0.008s) Memory: 1.9161 MB (Peak: 2.0380 MB) Zlib enabled. Server Time: 2019-10-18 19:50:27 UTC